Commit 8ca04990 authored by Pete Tucker's avatar Pete Tucker
Browse files

Add NXP license info to meta-volansys-gw layer

parent c5d64acf
This diff is collapsed.
This layer adds packages to the Vesta developer image that may be helpful to
customers writing applications that interact with NXP's Thread border router
code running on the 300R's R41Z module.
This layer should be used in conjunction with the meta-volansys-gw-demo layer,
since that layer contains additional components that are useful for
interacting with the NXP boarder router code, even if the demo itself is
disabled.
To use the meta-volansys-gw and meta-volansys-gw-demo layers:
1) In your vesta-gateway-bsp/sources directory, run:
git clone git@git.rigado.com:vesta/meta-volansys-gw.git
and
git clone git@git.rigado.com:vesta/meta-volansys-gw.git-demo
2) Add the following lines to your vesta-gateway-bsp/build/conf/bblayers.conf
file:
${BSPDIR}/sources/meta-volansys-gw \
${BSPDIR}/sources/meta-volansys-gw-demo \
3) Add the following line to the vesta-gateway-bsp/sources/meta-vesta/
recipes-vesta/images/vesta-image-developer.bb file's
IMAGE_INSTALL_append variable:
packagegroup-volansys-gw \
4) from vesta-gateway-bsp, run the command:
MACHINE=vesta-300 DISTRO=poky source setup-environment build
5) Run the command:
bitbake vesta-image-developer
SUMMARY = "Python bindings for the DBus inter-process communication system"
SECTION = "devel/python"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
DEPENDS = "expat dbus dbus-glib virtual/libintl"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
"
SRC_URI[md5sum] = "7372a588c83a7232b4e08159bfd48fe5"
SRC_URI[sha256sum] = "e2f1d6871f74fba23652e51d10873e54f71adab0525833c19bad9e99b1b2f9cc"
S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils3-base autotools pkgconfig
PACKAGECONFIG ?= ""
PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
FILES_${PN}-dev += "${libdir}/pkgconfig"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment